Duplikate über mehrere Spalten können mit einer Hilfsspalte identifiziert bzw. gezählt werden. Bei eindeutigen Zahlenwerten funktioniert dies auch über Kreuz, wenn die Min()– und Max()-Funktionen eingesetzt werden, da die Zahlenwerte der Größe nach sortiert werden. Dies ist auch nützlich, wenn beispielsweise eine überkreuzende Rechtevergabe oder dergleichen in IT-Systemen überprüft werden soll (Wirtschaftsprüfung). Die zu untersuchenden Spalten werden zu einem neuen String in der Hilfsspalte verkettet.

[D] =MIN(A3;B3)&"-"&MAX(A3:B3)&"-"&C3 [Hilfsspalte]

In der Hilfsspalte werden dann die Dupklikate per Zählewenn() gezählt oder durch eine bedingte Formatierung > Duplikate identifiziert.

MIN(A3;B3) gibt die kleinere von beiden Zahlen zurück, wenn mit Semikolon getrennt. MAX(A3:B3) gibt den größeren Wert der Matrix zurück, wenn mit Doppelpunkt getrennt (hier auch zwei Werte: A3 und B3).

[E] =ZÄHLENWENN($D:$D;D3)

Es wird in der gesamten Spalte D gesucht, ob Duplikate vorliegen.

A B C D E
Kundennr. A Kundennr. B Typ =MIN(A3;B3)&“-„&MAX(A3:B3)&“-„&C3 =ZÄHLENWENN($D:$D;D3)
1687 9746 Typ1 1687-9746-Typ1 3
5464 9746 Typ1 5464-9746-Typ1 1
4687 1687 Typ1 1687-4687-Typ1 1
5822 5464 Typ1 5464-5822-Typ1 1
4994 5822 Typ1 4994-5822-Typ1 1
1687 9746 Typ1 1687-9746-Typ1 3
9746 1687 Typ1 1687-9746-Typ1 3
9746 1687 Typ2 1687-9746-Typ2 1

 

 

=KGRÖSSTE(B3:F3;1)&KGRÖSSTE(B3:F3;2)&KGRÖSSTE(B3:F3;3)&KGRÖSSTE(B3:F3;4)&KGRÖSSTE(B3:F3;5)